Scheduled Maintenance
Incident Report for BlueFolder
Resolved
We have finished the scheduled maintenance.
Posted Mar 24, 2018 - 00:11 MDT
Identified
Our scheduled maintenance is still ongoing. The update saying it was completed is false. We apologize for the delay. One activity in particular is taking much longer than expected. As soon as it is complete, we can bring BlueFolder back online.
Posted Mar 23, 2018 - 23:35 MDT