We are continuing to work with our team to address the performance issues felt across BlueFolder last week. If you are experiencing a specific situation that is not functioning, please submit a support ticket. We will leave this issue open until we have a better sense that some of the updates and changes made in the last several days have achieved their desired results.
Posted Jun 30, 2025 - 11:04 MDT
Identified
We have identified several fixes that we will need to implement over the next several days. These will be implemented at times to cause the least amount of disruption as possible.
Thank you for your continued patience.
Posted Jun 27, 2025 - 20:14 MDT
Update
We are continuing to investigate this issue.
Posted Jun 27, 2025 - 13:37 MDT
Investigating
We have received several reports of performance degradation especially around work lists, reports, and search functions. We will update here as we progress through any updates we can make to improve performance. Some of that work will require a release which will likely happen this evening.