Outgoing Email Delivery
Incident Report for BlueFolder
Resolved
The issue has been resolved.
Posted Jun 09, 2020 - 21:52 MDT
Monitoring
The issue has been fixed and we are currently monitoring.
Posted Jun 09, 2020 - 16:36 MDT
Investigating
We are currently experiencing failures with our outgoing email.
Posted Jun 09, 2020 - 16:22 MDT
This incident affected: Web App, Mobile Web App, and API.